# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)\s([\.\d]+)/$1$2/gm;t' <<< "\"1 9.7 1 0.8\", \"7.6 7.5\", \"3.7 13.5\", \"8.6 1 5.8\""