package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d)\s([\.\d]+)`)
var str = `"1 9.7 1 0.8", "7.6 7.5", "3.7 13.5", "8.6 1 5.8"`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}