use strict;
my $str = '"1 9.7 1 0.8", "7.6 7.5", "3.7 13.5", "8.6 1 5.8"';
my $regex = qr/(\d)\s([\.\d]+)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";