// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d)\s([\.\d]+)").unwrap();
let string = "\"1 9.7 1 0.8\", \"7.6 7.5\", \"3.7 13.5\", \"8.6 1 5.8\"";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}