const regex = /(\d)\s([\.\d]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)\\s([\\.\\d]+)', 'gm')
const str = `"1 9.7 1 0.8", "7.6 7.5", "3.7 13.5", "8.6 1 5.8"`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);