re = /(\d)\s([\.\d]+)/m
str = '"1 9.7 1 0.8", "7.6 7.5", "3.7 13.5", "8.6 1 5.8"'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result