$re = '/(\d)\s([\.\d]+)/m';
$str = '"1 9.7 1 0.8", "7.6 7.5", "3.7 13.5", "8.6 1 5.8"';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;