import Foundation
let pattern = #"(\d)\s([\.\d]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #""1 9.7 1 0.8", "7.6 7.5", "3.7 13.5", "8.6 1 5.8""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)