# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n(\\/\*[^*]*\*\\/)|(\\/\\/[^*]*)|\n(--[^.].*)//g;t' <<< "sql = `HELLO 1
-- comments 1
HELLO 2
-- comments 2
HELLO3
`;"