const regex = /\n(\/\*[^*]*\*\/)|(\/\/[^*]*)|\n(--[^.].*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n(\\\/\\*[^*]*\\*\\\/)|(\\\/\\\/[^*]*)|\\n(--[^.].*)', 'g')
const str = `sql = \`HELLO 1
-- comments 1
HELLO 2
-- comments 2
HELLO3
\`;`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);