re = /\n(\/\*[^*]*\*\/)|(\/\/[^*]*)|\n(--[^.].*)/
str = 'sql = `HELLO 1
-- comments 1
HELLO 2
-- comments 2
HELLO3
`;'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result