$re = '/\n(\/\*[^*]*\*\/)|(\/\/[^*]*)|\n(--[^.].*)/';
$str = 'sql = `HELLO 1
-- comments 1
HELLO 2
-- comments 2
HELLO3
`;';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;