package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\n(\/\*[^*]*\*\/)|(\/\/[^*]*)|\n(--[^.].*)`)
var str = `sql = \`HELLO 1
-- comments 1
HELLO 2
-- comments 2
HELLO3
\`;`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}