#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\n(\/\*[^*]*\*\/)|(\/\/[^*]*)|\n(--[^.].*)"
Local $sString = "sql = `HELLO 1" & @CRLF & _
"-- comments 1" & @CRLF & _
"HELLO 2" & @CRLF & _
"-- comments 2" & @CRLF & _
"HELLO3" & @CRLF & _
"`;"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)