using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n(\/\*[^*]*\*\/)|(\/\/[^*]*)|\n(--[^.].*)";
string substitution = @"";
string input = @"sql = `HELLO 1
-- comments 1
HELLO 2
-- comments 2
HELLO3
`;";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}