// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\n(\/\*[^*]*\*\/)|(\/\/[^*]*)|\n(--[^.].*)").unwrap();
let string = "sql = `HELLO 1
-- comments 1
HELLO 2
-- comments 2
HELLO3
`;";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}