use strict;
my $str = 'sql = `HELLO 1
-- comments 1
HELLO 2
-- comments 2
HELLO3
`;';
my $regex = qr/\n(\/\*[^*]*\*\/)|(\/\/[^*]*)|\n(--[^.].*)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";