import Foundation
let pattern = #"\n(\/\*[^*]*\*\/)|(\/\/[^*]*)|\n(--[^.].*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
sql = `HELLO 1
-- comments 1
HELLO 2
-- comments 2
HELLO3
`;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)