# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:.|\s)*?(\\begin{.*?})(?:\s\\end{enumerate}\s*?)(\\questao.*)/$1\n/g;t' <<< "\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 1}
\end{enumerate}
\questao{1}
\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 2}
\end{enumerate}
\questao{2}
\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 3}
\end{enumerate}
\questao{2}"