import Foundation
let pattern = #"(?:.|\s)*?(\\begin{.*?})(?:\s\\end{enumerate}\s*?)(\\questao.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 1}
\end{enumerate}
\questao{1}
\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 2}
\end{enumerate}
\questao{2}
\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 3}
\end{enumerate}
\questao{2}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)