# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:.|\s)*?(\\begin{.*?})(?:\s\\end{enumerate}\s*?)(\\questao.*)"
test_str = ("\\begin{enumerate}\n"
"\\end{enumerate}\n\n"
"\\begin{enumerate}\n"
"\\end{enumerate}\n\n"
"\\begin{esse que eu quero 1}\n"
"\\end{enumerate}\n\n"
"\\questao{1}\n\n"
"\\begin{enumerate}\n"
"\\end{enumerate}\n\n"
"\\begin{enumerate}\n"
"\\end{enumerate}\n\n"
"\\begin{esse que eu quero 2}\n"
"\\end{enumerate}\n\n"
"\\questao{2}\n\n"
"\\begin{enumerate}\n"
"\\end{enumerate}\n\n"
"\\begin{enumerate}\n"
"\\end{enumerate}\n\n"
"\\begin{esse que eu quero 3}\n"
"\\end{enumerate}\n\n"
"\\questao{2}")
subst = "$1\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.