// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:.|\s)*?(\\begin{.*?})(?:\s\\end{enumerate}\s*?)(\\questao.*)").unwrap();
let string = "\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 1}
\\end{enumerate}
\\questao{1}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 2}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 3}
\\end{enumerate}
\\questao{2}";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}