package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:.|\s)*?(\\begin{.*?})(?:\s\\end{enumerate}\s*?)(\\questao.*)`)
var str = `\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 1}
\end{enumerate}
\questao{1}
\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 2}
\end{enumerate}
\questao{2}
\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 3}
\end{enumerate}
\questao{2}`
var substitution = "$1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}