use strict;
my $str = '\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 1}
\\end{enumerate}
\\questao{1}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 2}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 3}
\\end{enumerate}
\\questao{2}';
my $regex = qr/(?:.|\s)*?(\\begin{.*?})(?:\s\\end{enumerate}\s*?)(\\questao.*)/p;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";