using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.|\s)*?(\\begin{.*?})(?:\s\\end{enumerate}\s*?)(\\questao.*)";
string substitution = @"$1\n";
string input = @"\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 1}
\end{enumerate}
\questao{1}
\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 2}
\end{enumerate}
\questao{2}
\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\begin{esse que eu quero 3}
\end{enumerate}
\questao{2}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}