const regex = new RegExp('(?:.|\\s)*?(\\\\begin{.*?})(?:\\s\\\\end{enumerate}\\s*?)(\\\\questao.*)', 'g')
const str = `\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 1}
\\end{enumerate}
\\questao{1}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 2}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 3}
\\end{enumerate}
\\questao{2}`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);