re = /(?:.|\s)*?(\\begin{.*?})(?:\s\\end{enumerate}\s*?)(\\questao.*)/
str = '\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 1}
\\end{enumerate}
\\questao{1}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 2}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\begin{esse que eu quero 3}
\\end{enumerate}
\\questao{2}'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result