#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:.|\s)*?(\\begin{.*?})(?:\s\\end{enumerate}\s*?)(\\questao.*)"
Local $sString = "\begin{enumerate}" & @CRLF & _
"\end{enumerate}" & @CRLF & _
"" & @CRLF & _
"\begin{enumerate}" & @CRLF & _
"\end{enumerate}" & @CRLF & _
"" & @CRLF & _
"\begin{esse que eu quero 1}" & @CRLF & _
"\end{enumerate}" & @CRLF & _
"" & @CRLF & _
"\questao{1}" & @CRLF & _
"" & @CRLF & _
"\begin{enumerate}" & @CRLF & _
"\end{enumerate}" & @CRLF & _
"" & @CRLF & _
"\begin{enumerate}" & @CRLF & _
"\end{enumerate}" & @CRLF & _
"" & @CRLF & _
"\begin{esse que eu quero 2}" & @CRLF & _
"\end{enumerate}" & @CRLF & _
"" & @CRLF & _
"\questao{2}" & @CRLF & _
"" & @CRLF & _
"\begin{enumerate}" & @CRLF & _
"\end{enumerate}" & @CRLF & _
"" & @CRLF & _
"\begin{enumerate}" & @CRLF & _
"\end{enumerate}" & @CRLF & _
"" & @CRLF & _
"\begin{esse que eu quero 3}" & @CRLF & _
"\end{enumerate}" & @CRLF & _
"" & @CRLF & _
"\questao{2}"
Local $sSubst = "$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)