using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(@Column *\( *name *= *""(.+?)"".+)";
string substitution = @"$1\n\t@BeanStructProperty(uniqueName = ""$2"")";
string input = @" @Column(name = ""UTL_DA_PRTCPZN_IC"", table = ""ALL_PRQZN_SEZ_PRNCPL"")
private Importo utiliDaPartecipazioneIC;
@Column(name = ""UTL_DA_PRTCPZN_IFD"", table = ""ALL_PRQZN_SEZ_PRNCPL"")
private Importo utiliDaPartecipazioneIFD;
@Column(name = ""PRQZN_RDZN_PRTCPZN_UTL_ALQ_IC"", table = ""ALL_PRQZN_SEZ_PRNCPL"")
private Aliquota riduzionePartecipazioniAliquotaIC;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}