use strict;
my $str = ' @Column(name = "UTL_DA_PRTCPZN_IC", table = "ALL_PRQZN_SEZ_PRNCPL")
private Importo utiliDaPartecipazioneIC;
@Column(name = "UTL_DA_PRTCPZN_IFD", table = "ALL_PRQZN_SEZ_PRNCPL")
private Importo utiliDaPartecipazioneIFD;
@Column(name = "PRQZN_RDZN_PRTCPZN_UTL_ALQ_IC", table = "ALL_PRQZN_SEZ_PRNCPL")
private Aliquota riduzionePartecipazioniAliquotaIC;';
my $regex = qr/(@Column *\( *name *= *"(.+?)".+)/mp;
my $subst = '$1\\n\\t@BeanStructProperty(uniqueName = "$2")';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";