const regex = /(@Column *\( *name *= *"(.+?)".+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(@Column *\\( *name *= *"(.+?)".+)', 'gm')
const str = ` @Column(name = "UTL_DA_PRTCPZN_IC", table = "ALL_PRQZN_SEZ_PRNCPL")
private Importo utiliDaPartecipazioneIC;
@Column(name = "UTL_DA_PRTCPZN_IFD", table = "ALL_PRQZN_SEZ_PRNCPL")
private Importo utiliDaPartecipazioneIFD;
@Column(name = "PRQZN_RDZN_PRTCPZN_UTL_ALQ_IC", table = "ALL_PRQZN_SEZ_PRNCPL")
private Aliquota riduzionePartecipazioniAliquotaIC;`;
const subst = `$1\n\t@BeanStructProperty(uniqueName = "$2")`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);