# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z-]+)(<\\/)/NEW-TEXT$2/gm;t' <<< "<div class=\"TEST-TEXT\">hi</span><a href=\\"https://en.wikipedia.org/wiki/TEST-TEXT\\">first young CEO's
TEST-TEXT</a><span class=\"test\">hello</span><div class=\"TEST-TEXT\">hi</span><a href=\\"https://en.wikipedia.org/wiki/TEST-TEXT\\">first young CEO's
TEST-TEXT</a><span class=\"test\">hello</span>"