#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([A-Z-]+)(<\/)"
Local $sString = "<div class="TEST-TEXT">hi</span><a href=\"https://en.wikipedia.org/wiki/TEST-TEXT\">first young CEO's" & @CRLF & _
"TEST-TEXT</a><span class="test">hello</span><div class="TEST-TEXT">hi</span><a href=\"https://en.wikipedia.org/wiki/TEST-TEXT\">first young CEO's" & @CRLF & _
"TEST-TEXT</a><span class="test">hello</span>"
Local $sSubst = "NEW-TEXT$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)