$re = '/([A-Z-]+)(<\/)/m';
$str = '<div class="TEST-TEXT">hi</span><a href=\\"https://en.wikipedia.org/wiki/TEST-TEXT\\">first young CEO\'s
TEST-TEXT</a><span class="test">hello</span><div class="TEST-TEXT">hi</span><a href=\\"https://en.wikipedia.org/wiki/TEST-TEXT\\">first young CEO\'s
TEST-TEXT</a><span class="test">hello</span>';
$subst = "NEW-TEXT$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;