using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z-]+)(<\/)";
string substitution = @"NEW-TEXT$2";
string input = @"<div class=""TEST-TEXT"">hi</span><a href=\""https://en.wikipedia.org/wiki/TEST-TEXT\"">first young CEO's
TEST-TEXT</a><span class=""test"">hello</span><div class=""TEST-TEXT"">hi</span><a href=\""https://en.wikipedia.org/wiki/TEST-TEXT\"">first young CEO's
TEST-TEXT</a><span class=""test"">hello</span>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}