# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([A-Z-]+)(<\/)"
test_str = ("<div class=\"TEST-TEXT\">hi</span><a href=\\\"https://en.wikipedia.org/wiki/TEST-TEXT\\\">first young CEO's\n"
"TEST-TEXT</a><span class=\"test\">hello</span><div class=\"TEST-TEXT\">hi</span><a href=\\\"https://en.wikipedia.org/wiki/TEST-TEXT\\\">first young CEO's\n"
"TEST-TEXT</a><span class=\"test\">hello</span>")
subst = "NEW-TEXT$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.