package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z-]+)(<\/)`)
var str = `<div class="TEST-TEXT">hi</span><a href=\"https://en.wikipedia.org/wiki/TEST-TEXT\">first young CEO's
TEST-TEXT</a><span class="test">hello</span><div class="TEST-TEXT">hi</span><a href=\"https://en.wikipedia.org/wiki/TEST-TEXT\">first young CEO's
TEST-TEXT</a><span class="test">hello</span>`
var substitution = "NEW-TEXT$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}