// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z-]+)(<\/)").unwrap();
let string = "<div class=\"TEST-TEXT\">hi</span><a href=\\\"https://en.wikipedia.org/wiki/TEST-TEXT\\\">first young CEO's
TEST-TEXT</a><span class=\"test\">hello</span><div class=\"TEST-TEXT\">hi</span><a href=\\\"https://en.wikipedia.org/wiki/TEST-TEXT\\\">first young CEO's
TEST-TEXT</a><span class=\"test\">hello</span>";
let substitution = "NEW-TEXT$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}