import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z-]+)(<\\/)";
final String string = "<div class=\"TEST-TEXT\">hi</span><a href=\\\"https://en.wikipedia.org/wiki/TEST-TEXT\\\">first young CEO's\n"
+ "TEST-TEXT</a><span class=\"test\">hello</span><div class=\"TEST-TEXT\">hi</span><a href=\\\"https://en.wikipedia.org/wiki/TEST-TEXT\\\">first young CEO's\n"
+ "TEST-TEXT</a><span class=\"test\">hello</span>";
final String subst = "NEW-TEXT$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}