re = /([A-Z-]+)(<\/)/m
str = '<div class="TEST-TEXT">hi</span><a href=\\"https://en.wikipedia.org/wiki/TEST-TEXT\\">first young CEO\'s
TEST-TEXT</a><span class="test">hello</span><div class="TEST-TEXT">hi</span><a href=\\"https://en.wikipedia.org/wiki/TEST-TEXT\\">first young CEO\'s
TEST-TEXT</a><span class="test">hello</span>'
subst = 'NEW-TEXT$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result