use strict;
my $str = '<div class="TEST-TEXT">hi</span><a href=\\"https://en.wikipedia.org/wiki/TEST-TEXT\\">first young CEO\'s
TEST-TEXT</a><span class="test">hello</span><div class="TEST-TEXT">hi</span><a href=\\"https://en.wikipedia.org/wiki/TEST-TEXT\\">first young CEO\'s
TEST-TEXT</a><span class="test">hello</span>';
my $regex = qr/([A-Z-]+)(<\/)/mp;
my $subst = 'NEW-TEXT$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";