#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)^(.*)$\n.*,\s(.*)$"
Local $sString = "Awakening" & @CRLF & _
"" & @CRLF & _
"En-Core, Malyarovsky Maxim, Nikita"
Local $sSubst = "$1 - $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)