const regex = /^(.*)$\n.*,\s(.*)$/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)$\\n.*,\\s(.*)$', 'gms')
const str = `Awakening
En-Core, Malyarovsky Maxim, Nikita`;
const subst = `$1 - $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);