using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)$\n.*,\s(.*)$";
string substitution = @"$1 - $2";
string input = @"Awakening
En-Core, Malyarovsky Maxim, Nikita";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}