re = /^(.*)$\n.*,\s(.*)$/m
str = 'Awakening
En-Core, Malyarovsky Maxim, Nikita'
subst = '$1 - $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result