// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)^(.*)$\n.*,\s(.*)$").unwrap();
let string = "Awakening
En-Core, Malyarovsky Maxim, Nikita";
let substitution = "$1 - $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}