import re
regex = re.compile(r"^(.*)$\n.*,\s(.*)$", flags=re.MULTILINE | re.DOTALL)
test_str = ("Awakening\n\n"
"En-Core, Malyarovsky Maxim, Nikita")
subst = "$1 - $2"
result = regex.sub(subst, test_str)
if result:
print(result)