# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\((?=\S))|((?<=\S)\))/( /gm;t' <<< "blabla (text blabla)
blabla (100 text blabla 100)
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
Titel mit nur (einer öffnenden Klammer
Titel b) mit nur einer schliessenden Klammer
Titel c) und Titel d) ohne öffnende Klammer
Titel mit schliessender) Klammer vor (öffnender Klammer"