import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\((?=\\S))|((?<=\\S)\\))";
final String string = "blabla (text blabla)\n"
+ "blabla (100 text blabla 100)\n"
+ "blabla ( text blabla )\n"
+ "blabla ( text blabla )\n"
+ "blabla ( text blabla )\n"
+ "blabla ( text blabla )\n\n"
+ "Titel mit nur (einer öffnenden Klammer\n"
+ "Titel b) mit nur einer schliessenden Klammer\n"
+ "Titel c) und Titel d) ohne öffnende Klammer\n"
+ "Titel mit schliessender) Klammer vor (öffnender Klammer";
final String subst = "( ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}