use strict;
my $str = 'blabla (text blabla)
blabla (100 text blabla 100)
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
Titel mit nur (einer öffnenden Klammer
Titel b) mit nur einer schliessenden Klammer
Titel c) und Titel d) ohne öffnende Klammer
Titel mit schliessender) Klammer vor (öffnender Klammer';
my $regex = qr/(\((?=\S))|((?<=\S)\))/mp;
my $subst = '( ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";